
1. Overview
        In this tutorial, I will first briefly introduce the purpose of Meat for NGG9 and the software that this 
add-on relies on. Then we will install these software to set up the running environment of Meat add-on. At 
last, we will make two animations to introduce the use of Meat for NGG9 in detail.

2. The purpose of Meat add-on
        If we want to make an animation in DAZ Studio to show the interaction between female genitals and 
male genitals or toys, we not only need to animate the male genitals or toys, but also need to use NGG9's 
morphs to change its shape in each frame to simulate the changes in the appearance of female genitals 
when interacting with other objects in the real world. This is a tedious and time-consuming task. Now with 
Meat for NGG9, we only need to focus on designing the animation of male genitals or toys. The Meat add-
on will make NGG9 automatically change its shape when interacting with other objects.

3. Installation
        3.1 Install Blender
        Meat for NGG9 is divided into two parts: one that runs in DAZ Studio and the other that runs in 
Blender. Therefore, in addition to DAZ Studio, we also need to install Blender. This software is free, and you 
can download its latest version from the following page:
        https://www.blender.org/download/releases/
        We don't need to set up Blender, as long as it can start properly.

 3.2 Install Sagan
        Sagan is a free DAZ Studio plug-in. It can save the animation scene we made in DAZ Studio 
completely as an alembic file, and then we can import this alembic file in Blender and play the animation.
        Please get the latest version of Sagan from the following page:
        https://www.daz3d.com/forums/discussion/428856/sagan-a-daz-studio-to-blender-alembic-exporter

        The installation of Sagan is very 
simple. We just need to copy the .dll file 
in its installation package to the plug-in 
folder of DAZ Studio, and then restart 
DAZ Studio. 

        The following is a video tutorial on 
how to install Sagan:
        https://rumble.com/v1ojvso-
installing-sagan-alembic-daz-to-blender-
pipline-tutorial-1.html

        After installing, we need to 
manually configure Sagan to appear in 
DAZ Studio's menu. In DAZ Studio's 
Windows menu, select 'Workspace > 
Customize...', find 'Sagan' on the left-
side pane under 'Miscellaneous', and 
drag it to the desired location on the 
Menus tab of the right-side pane. For 
example, under File menu.



        Double-click 'import_daz'. You will see a subfolder called 'to_daz_studio'. This contains the part of DAZ 
Importer that runs in DAZ Studio (DAZ scripts). This subfolder contains a separate folder called 'Scripts'. 
Please copy the 'Scripts' folder to one of your DAZ Studio library folders.

        3.3 Install Diffeomorphic
        Diffeomorphic is a free toolkit. Its DAZ Importer add-on can help us import the entire DAZ Studio 
scene into Blender. You may wonder why we need to install both Sagan and DAZ Importer with similar 
functions. This is because they will be used to deal with different scenarios. Simply put, in an animation, 
when NGG9 interacts with an object, If NGG9 is stationary and the object is moving, we should use Sagan. 
Otherwise, if NGG9 is moving and the object is stationary, then we must use DAZ Importer. I will explain 
this further in the examples.
        Now, please download the latest stable version of DAZ Importer from the following page:
        https://bitbucket.org/Diffeomorphic/import_daz/wiki/Home
        This page already contains detailed installation and usage tutorial of DAZ Importer. You can also 
install DAZ Importer by following the steps below:

        3.3.1. In the zip file we downloaded, there is a subfolder called 'import_daz', which is the DAZ 
Importer add-on we need. 



        3.3.3. Double-click the 
script 'Setup Menus' and 4 new 
menu items will be added to DAZ 
Studio's File menu. These menu 
items link to the scripts in the 
Diffeomorphic subfolder. So in 
the future we will be able to 
quickly execute these scripts 
from the File menu, which is very 
convenient.
        

        3.3.2. Now start DAZ 
Studio. In the Content Library 
pane, open the Scripts folder and 
then the Diffeomorphic subfolder. 
It contains six scripts.

        3.3.4. The part of DAZ 
Importer that runs in Blender 
(Blender add-on) needs to know 
the paths to all the DAZ assets in 
order to import the DAZ Studio 
scenes into Blender properly. So 
all the root paths of DAZ Studio 
need to be passed to Blender via 
a JSON file. In the File menu of 
DAZ Studio select 'Save Root 
Paths' and then select a folder to 
save the JSON file in the file 
selection window that pops up.



        3.3.5. Next, install and configure the Blender add-on for DAZ Importer. Open Blender, click 'Edit > 
Preferences...' to open the Blender Preferences window. In the Add-ons tab, press the 'Install...' button to 
open the file selector. Navigate to the downloaded zip file and press 'Install Add-on'.

        3.3.6. The add-on is now copied to your Blender add-ons folder. Select the checkbox on the left to 
enable the DAZ importer. New tabs named 'DAZ Setup' and 'DAZ Runtime' now appear in the UI panel to 
the right of the viewport.



        3.3.7. Click on the DAZ Setup tab. Press the 'Global Settings' button to open the settings dialog, and 
then press the 'Load Root Paths' button. In the file selector, find the JSON file containing the root paths 
that you saved earlier in DAZ Studio. At last, press the 'Load Root Paths' button.



        3.4 Install the daz script of Meat for NGG9

        Similar to DAZ Importer, Meat for 
NGG9 is also divided into the daz script 
that runs in DAZ Studio and the add-on 
that runs in Blender. Let's install the daz 
script first. Double-click to open 
Meat_daz_studio.zip and copy 'People' 
folder to the DAZ Studio library folder 
where NGG9 is located.

        Unzip the Meat for 
NGG9 zip file to a temporary 
folder and we will get two 
new zip files, 
Meat_daz_studio.zip and 
Meat_blender.zip.



        After copying, start DAZ Studio. In the 
Content Library pane, under 'People > Genesis 9 > 
Anatomy > New Genitalia for Genesis 9 > Meat for 
NGG9'. You will see a script called 'Meat for NGG9'. 
This script is used to convert the obj sequence 
exported from Blender into NGG9 keyframe 
animation in DAZ Studio.

        3.5 Installing the Blender add-on of Meat for NGG9
        Open Blender, 
click 'Edit > 
Preferences...' to 
open the Blender 
Preferences 
window. In the 
Add-ons tab, press 
the 'Install...' 
button to open the 
file selector. 
Navigate to the 
'Meat_blender.zip' 
and press 'Install 
Add-on'. 

        The add-on is 
now copied to your 
Blender add-ons 
folder. Select the 
checkbox on the 
left to enable Meat 
for NGG9. Then a 
new tab named 
'Meat for NGG9' 
now appears in the 
UI panel to the 
right of the 
viewport.



4. Example 1
        First, we will create a simple animation in DAZ Studio with only one character and one toy. In this 
animation, we let the character remain motionless while the sphere is extruded and falls from the inside of 
NGG9.



        Of course, the sphere now only pass 
through the surface of the NGG9 model 
without causing any changes to its shape.

        Next, we will use the Meat add-on in 
Blender to add shape variations to NGG9. As 
mentioned earlier, since it is mainly the object 
(the sphere) that is moving, we will then 
export this animation to Blender using the 
Sagan plug-in.

        Please note: When animating, we need 
to be aware that the range of motion of male 
genitals/toys is actually limited. After all, in 
reality, their range of motion is also limited by 
the female physiological structure.

        4.1 When making animations, find the FPS in the Timeline pane and set its value to 24.

        If we don't set the FPS to 24, then after importing the alembic file in Blender, we will find that the 
frame number of the imported animation is inconsistent with the frame number in DAZ Studio. This is what 
we do not want to see.
        After setting the FPS, save the scene.

        4.2 (Optional) Hide all nodes in the 
scene except the character, NGG9 and the toy. 
This step is not necessary, it is mainly for the 
consideration of saving space. Because Sagan 
ignores hidden nodes by default. If your scene 
is very complex, doing this can significantly 
reduce the size of the alembic file. 



        4.3 Select the character in 
the scene, and in the Parameter 
pane, set its Resolution Level to 
'Base' and View SubD Level to 0. 
Similarly, select NGG9 in the 
scene, and in the Parameter 
pane, set its Resolution Level to 
'Base' and View SubD Level to 0. 
This is to ensure that the obj 
sequence exported after running 
the Meat add-on in Blender can 
be correctly imported as NGG9's 
morphs.

        4.4 Go to DAZ Studio's File menu and click 'Sagan Alembic Exporter v3'. In 
the pop-up window, click the 'Choose Base Directory' button to select a folder. 
The Sagan plug-in will create a subfolder named after your scene in this folder 
and then store the alembic file in the subfolder.

        4.5 (Optional) Check 'Overwrite Export Directory Instead of Numbered 
Versions'. This way if we export the animation again, the Sagan plug-in will 
overwrite the last saved alembic file instead of creating a new version for it.

        4.6 Make sure 'Current SubD Level' is checked in the 'Blender/Houdini (m)' 
column, then click the 'Export' button to start the export.



        4.8 After the import is complete, hide all objects except NGG9 and the sphere in the outline. Then 
select NGG9 and click the 'Meat for NGG9' tab in the UI panel on the right side of the viewport.

        4.7 Open Blender, delete all default objects, select 'File > Import > Alembic (.abc)', find the alembic 
file we exported in the previous step in the Blender File View window, and then click the 'Import Alembic' 
button.



        4.9 We can see that the Meat add-on has a very simple user interface. User can click the Target 
column and select the sphere as the target object from the drop-down list. Or click the eyedropper on the 
right side of the Target column and then click the sphere in the viewport or outline.

        4.10 The default value of Distance to Target is 0.001, which is 
1mm. After applying the Meat add-on, if you find that poke-through 
occurs between the sphere and NGG9 when playing the animation, you 
can go back here and slightly increase the value of Distance to Target 
to eliminate this phenomenon.

        4.11 After setting the target, make sure NGG9 is selected and click 'Apply add-on' to apply the Meat 
add-on. Then press the spacebar to play the animation, or manually drag the time slider to observe the 
shape changes of NGG9 in each frame.

        4.12 Please note that if poke-through is found, we need to select NGG9 again and click the 'Read 
parameters' button, only in this way can we correctly adjust the value of Distance to Target. This is because 
there may be multiple NGG9s in the scene, and the Meat add-on needs to get the parameters of a NGG9 
before the user can modify them. If we need to change the Target, the same steps are required.

        4.13 Now we are going to export the obj sequence. Select NGG9 and choose 'Export > Wavefront 
(.obj)'. In the Blender File View window, select a folder to store the obj sequence and set the file name of 
the .obj file. On the right side of the window, check 'Selected Only' and change 'Scale' to 100. Find 
'Animtaion' and check 'Export' to its right. At last, click the 'Export Wavefront OBJ' button.



        4.14 Return to DAZ Studio, reload the animation 
scene and select NGG9. In the Content Library pane, go to 
'People > Genesis 9 > Anatomy > New Genitalia for Genesis 
9 > Meat for NGG9' and run the Meat for NGG9 script.



        4.15 In the Import Obj Sequence window, select the folder where the obj sequence is located, enter 
the file name we set for the .obj file, and then click the 'Start' button. The script starts importing the obj 
sequence, automatically creates morphs, and uses these morphs to make keyframe animations for NGG9.

        4.16 When the script is finished, open the Timeline pane, play the animation or drag the time slider 
to view the shape changes of NGG9. At this point, the interaction animation of NGG9 and the sphere is 
complete.

5. Example 2
        Next we will make a lesbian sex 
animation. In this scene, the toy is basically 
not moving, just the characters are moving. 
So, after setting up the animation of the 
characters, we should import them into 
Blender using the DAZ Importer add-on.

        5.1 Let's first save each character's animation as a pose preset. In the step 5.8, the DAZ Importer will 
use these pose presets to load the animations to the characters in the Blender scene. Select Sarah HD in 
the scene, then select 'Save As > Pose Preset...' in the File menu of DAZ Studio. Select a folder in the 
Filtered Save window and give the pose preset a name, such as 'Sarah action'. Then click the 'Save' button.



        5.2 In the pop-up Pose Preset Save Options window, select 'Animated Range' for the animation 
range, and keep the other options as default. Then click the 'Accept' button. In the same way, save Victoria 
9's animation as a pose preset called 'Victoria action'.

        5.3 Save the scene as a replica scene 
(assuming the original scene is 'example02', 
we can name its replica scene 
'example02_export'). This replica scene will 
be imported into Blender using DAZ 
Importer. Before that, we should return the 
two characters to base pose. Select Sarah 
HD and select 'Figure > Zero > Zero Figure 
Pose' in the Edit menu of DAZ Studio. Then 
select Victoria 9 and do the same thing.



        5.4 Once both characters have returned to their base pose, save the replica scene. Then, in DAZ 
Studio's File menu, select 'Export to Blender', then select a folder in the pop-up dialog and press the 'Save' 
button.

        5.5 Start Blender and click 'DAZ Setup' in the UI panel to the right of the viewport. Press 'Easy Import 
DAZ' button to open the file selector. Navigate to the folder where the example02_export.duf is located.

        5.6 Select example02_export.duf, then find and check 'JCMs' in the parameter list on the right, and 
then press the 'Easy Import DAZ' button to import the replica scene into Blender.



        5.7 Select one of the NGG9s and click the 'Meat for NGG9' tab in the UI panel on the right side of the 
viewport. The Meat add-on's user interface has been introduced in Example 1. We just need to set the toy 
as the Target and click 'Apply add-on'. Then select the other NGG9 and click 'Apply add-on' as well.



        5.8 Next, load animations for both characters. Select Sarah HD's armature in the viewport and click 
'DAZ Runtime' in the UI panel to the right of the viewport. Expand the 'Posing' column and click 'Import 
Action'. In the Blender File View window, find and select the Sarah action.duf we saved in the first step and 
click the 'Import Action' button. Similarly, select Victoria 9's armature in the viewport and import animations 
for it in the same way.



        Please note: Usually the animation loaded through DAZ Importer starts from frame 1. Take this 
animation we made as an example, it starts from frame 0 and ends at frame 120, with a total length of 121 
frames. When this animation is loaded to the character by DAZ Importer, its length remains unchanged, 
but the start frame becomes frame 1, and the end frame becomes frame 121. This inconsistency has no 
effect on our use of the Meat add-on. But when exporting the obj sequence, we need to remember to 
manually set the correct start frame and end frame (from frame 1 to frame 121). Otherwise, an error of 
insufficient obj sequence length may occur when importing the obj sequence in DAZ Studio.

        5.9 Now hide all objects except the two NGG9s and the toy in the outline, press the spacebar to play 
the animation, or manually drag the time slider to observe the shape changes of the two NGG9s in each 
frame. If poke-through is found, we can select the problematic NGG9, click the 'Read parameters' button, 
and then slightly increase the value of Distance to Target to eliminate this phenomenon.

        5.10 Next we are going to export the obj sequence. Select the NGG9 corresponding to Sarah HD and 
choose 'Export > Wavefront (.obj)'. In the Blender File View window, choose a folder to store the obj 
sequence and set the file name of the .obj file (for example, 'sarah gens'). On the right side of the window, 
check 'Selected Only' and change 'Scale' to 100. Find 'Animation' and check 'Export' to the right of it. Set 
'Frame Start' to 1 and 'End' to 121. At last, click the 'Export Wavefront OBJ' button. After the export is 
finished, select the NGG9 corresponding to Victoria 9 and export the obj sequence in the same way (set the 
file name of the .obj file to 'victoria gens').



        5.11 Back in DAZ Studio, load example02.duf. Select the NGG9 that was applied to Sarah HD. In the 
Content Library pane, go to 'People > Genesis 9 > Anatomy > New Genitalia for Genesis 9 > Meat for 
NGG9' and run the Meat for NGG9 script.

        5.12 In the Import Obj 
Sequence window, select the folder 
where the obj sequence is located, 
enter the file name we set for 
the .obj file ('sarah gens'), and then 
click the 'Start' button. The script 
starts importing the obj sequence, 
automatically creates morphs, and 
uses these morphs to make 
keyframe animations for NGG9 
applied to Sarah HD.



        5.13 Use the same steps to create keyframe animation for the NGG9 applied to Victoria 9.

        5.14 Open the Timeline pane, play the animation or drag the time slider to view the shape changes 
of the two NGG9s. At this point, the lesbian sex animation is complete.


	Local Disk
	file:///D/01 My Works/Daz/Meat project - new/docs/用户手册 - eng.txt

	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page
	Blank Page

